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About PugetBench

Adobe's Creative Cloud suite includes industry leading applications for graphic design,
photography, video editing, and a host of other creative workflows. Even though these
applications are all developed by Adobe, each utilizes the hardware in a computer in very
different and unique ways. Because of this, it can be extremely difficult to determine exactly
what hardware will give the end user the best possible performance.

Due to a lack of repeatable and consistent benchmarks for these popular applications, we
decided to develop our own set of benchmarks. Our suite of Adobe CC benchmarks are
designed to thoroughly test many of Adobe's most popular software packages using real world
projects and workflows and are used in many of our hardware analysis articles.

We have free versions of our benchmarks available that allow individuals to evaluate the
performance of their own system, but also a licensed version that include features that are often
desired by those performing testing for commercial applications (system reviewers,
hardware/software developers, workstation manufacturers, etc.).

More information on the licensed version - including licensing options - is available at
https://www.pugetsystems.com/go/PugetBench_Adobe

Feature Free Edition Commercial Edition

Benchmark Scores ✔ ✔

Result Upload ✔ ✔

Windows Support ✔ ✔

MacOS Support Varies Varies

CLI Automation ✔

.CSV Logging ✔

Licensed for Commercial Use ✔

Support Community Email
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Detailed information on the individual benchmarks (what is tested, system requirements,
supported application versions, etc.) is available at:

● Photoshop - https://www.pugetsystems.com/go/PSBenchmark
● Lightroom Classic - https://www.pugetsystems.com/go/LRBenchmark
● Premiere Pro - https://www.pugetsystems.com/go/PRBenchmark
● After Effects - https://www.pugetsystems.com/go/AEBenchmark

If you wish to compare your results to other systems, you can browse all the uploaded results
are https://www.pugetsystems.com/benchmarks/index.php

We also have several benchmarks available for other applications outside of the Adobe
ecosystem. You can view the full list at
https://www.pugetsystems.com/all_articles.php?filter[]=Benchmark

Download Links

The latest links to download the benchmarks either through the Adobe Marketplace or the
manual ZXP package is available on the main benchmark page:
https://www.pugetsystems.com/go/PugetBench_Adobe

How to Install the Benchmark Plugin

Our benchmarks are all packaged as Adobe plugins and must be installed before you can run
the benchmark. Most of our benchmarks currently allow two methods to install the benchmark
packages: through the Adobe Marketplace, or manually with a ZXP package. Lightroom Classic
is the exception and requires manual installation of the plugin

PugetBench for Photoshop / After Effects / Premiere Pro:

Installation via Adobe Marketplace:
1. From https://www.pugetsystems.com/go/PugetBench_Adobe, click on the link for the

relevant benchmark for “Get on Adobe Marketplace”
2. Log in with your Creative Cloud account
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3. Click on the “Free” button on the top-right, then click on “Install Now” once it is added to
your account

4. Follow the instructions to complete installation in the Creative Cloud app

Installation via ZXP package
1. Download the ZXP package using the “Alt: Download ZXP Package” link on

https://www.pugetsystems.com/go/PugetBench_Adobe
2. Double-click on the package to allow Creative Cloud to install it.
3. Note - often new versions of Adobe applications are not fully supported by the ZXP

installer. You may see a message that there is no supported applications found on your
system, but you can choose to install the plugin anyways.

Premiere Pro Test Assets
The Premiere Pro benchmark requires additional test assets to be downloaded in addition to the
plugin itself. These assets can be downloaded from
https://www.pugetsystems.com/go/PugetBench_Adobe using the “Download Test Assets” link
under PugetBench for Premiere Pro

PugetBench for Lightroom Classic
1. From https://www.pugetsystems.com/go/PugetBench_Adobe, click on the link to

“Download Plugin & Assets” for PugetBench for Lightroom Classic
2. Install Option 1:

a. Copy the pugetsystems.lrplugin folder to
“C:\Users\<USERNAME>\AppData\Roaming\Adobe\Lightroom\Modules"

3. Install Option 2:
1. Launch Lightroom Classic
2. Go to "File -> Plug-in Manager"
3. Click "Add"
4. Navigate to the location of the benchmark folder and select the

"pugetsystems.lrplugin" folder
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5. Click "Done”

Required Application Preferences

Since our benchmarks test each Adobe application in the most real-world ways possible, there
are very few settings that need to be changed before the benchmark can be run. If you have a
commercial license, these required settings are automatically set by the CLI utility, but it does
NOT overwrite settings for GPU acceleration, cache location, reserved RAM, etc.

We highly recommend checking to make sure important settings like GPU acceleration
are properly configured before running the benchmark.

Photoshop
● No settings required

Premiere Pro
● Windows:

○ Make sure the workspace has the preview panel in the upper-right of your
screen. Screenshot of the placement is shown when you open the benchmark
.prproj file

● MacOS:
○ Navigate to “Security & Privacy -> Accessibility” in your OS and add Premiere

Pro as an app that has permission to control your computer
○ The first time the benchmark runs, you will need to click OK on the popup in

order to allow Premiere Pro to control “System Events”
○ Screenshots of both settings are shown when you open the benchmark .prproj

file

After Effects
● Enable “Allow Scripts to Write Files and Access Network” in "Edit -> Preferences ->

Scripts & Expressions"

Lightroom Classic
● Disable “Getting Started with Lightroom” tips - These tips pop up the first time you enter

each module, and can be disabled by clicking the “Turn Off Tips” checkbox when one of
them comes up.
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Starting the Benchmark Plugin

In order to run the benchmark, the plugin must be loaded and in some cases, a specific project
file must be opened. If you have a license key, you can alternatively use the CLI utility on
Windows to run the benchmark automatically.

Photoshop / After Effects
1. Launch the Adobe application
2. Go to either “Window -> Extensions -> PugetBench for ____” or  "Window->Extensions

(Legacy)->PugetBench for ____" depending on your application version.

Premiere Pro
3. Launch Premiere Pro
4. Open the benchmark project from the test assets.

a. If using Premiere Pro 2020 (14.x), use the “Benchmark_Project.prproj” file.
b. If using Premiere Pro 2021 (15.x), use the “Benchmark_Project_15.prproj” file.
c. If using Premiere Pro 2022 (22.x), use the “Benchmark_Project_22.prproj” file.

5. Launch the plugin from “Window -> Extensions -> PugetBench for Premiere Pro”

Lightroom Classic
1. Launch Lightroom Classic
2. Open the "Benchmark Catalog.lrcat" file by going to "File -> Open Catalog"
3. Go to "File -> Plug-in Extras -> Benchmark Run" to start the benchmark plugin

Manually Running the Benchmark

The plugin allows you to quickly run the benchmark with default settings, or allows you to
customize various aspects of the benchmark.
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Test Type
Depending on the benchmark, this allows for different test presets to be run. All benchmarks
include a “Standard” preset, but many also have an “Extended” preset that includes additional
tests and/or a “Custom” preset (if you have a license key) that allows you to choose individual
tests to run.

Export Location
For benchmarks that include tests that can be influenced by the speed or your storage drive,
there is the option to set what location to export or save to. By default, this is
“Documents\PugetBench\*APPNAME*”

Automation Settings (Requires License)
When using a licensed version of PugetBench, several settings are unlocked to assist in running
the benchmark for commercial purposes. These settings are all also configurable or auto-set via
the Command Line Utility.

These settings are unlocked when you input your license key using the “Change” button.

8



● Do NOT upload results - Checked by default when a license is first entered, this will
prevent the benchmark from uploading the results to the PugetBench online database.
This option is automatically selected if you are using the CLI utility unless you use the
“\upload_results” argument.

● Automatically run on startup - The benchmark will auto-start with the last saved
settings the next time the plugin is loaded. This option is automatically selected if you are
using the CLI utility.

● Write CSV/JSON log file - Writes the benchmark results to a CSV and JSON log file to
a “Documents\PugetBench\*APPNAME*\*TIMESTAMP*” folder. Note that if you are
using the CLI utility, this is automatically selected, but you can also use the “\copy_log”
argument to copy the CSV log file to a custom location.

● Suppress dialog boxes - Hides any dialog boxes such as the startup and benchmark
complete dialogs, but does not hide any warning/error boxes. This option is automatically
selected if you are using the CLI utility.

● Exit app on completion - When the benchmark is done running, will attempt to close
the benchmarked application. This option is automatically selected if you are using the
CLI utility.

● Run custom commands - *Premiere Pro & Windows only* Launches custom .bat files
stored in C:/PugetBenchCommand at various points during the benchmark. See next
section for detailed information.

Custom Commands (Requires License)

PugetBench for Premiere Pro (Windows version only) has the ability to run custom commands
via .bat files at various points during the benchmark. These .bat files can be used for numerous
reasons, but the most popular is using them to start/stop Windows Performance Recorder and
adding markers at the start/end of individual tests.

If the .bat files include commands that require admin privileges, you must run Premiere
Pro (or the CLI) as administrator.

The .bat files must be located in C:\PugetBenchCommand and you can utilize up to four types
of .bat files:

● BenchmarkStart.bat - This .bat file is launched after the benchmark has started, just
before the first test is run.

● BenchmarkEnd.bat - This .bat file is launched after the benchmark has completed, after
the tests are completed and the scores compiled.
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● TestStart.bat - This .bat file is launched immediately before each individual test is run. It
will run after the majority of the test setup is completed (setting resolution, linked media,
etc.), and as such should trigger right before the performance portion of the test.

● TestEnd.bat - This .bat file is launched after each individual test completes.

When the benchmark launches these files, it runs them with a single command line argument
with information on the benchmark and/or test. You can use “%1” to pull the text of this
argument to use for things like WPR marker names.

To act as a starting point, you can download sample .bat files that are configured for WPR
logging which you can tweak to your needs.

Command Line Utility (Requires License)

The PugetBench CLI utility for Windows systems is located in the plugin directory within the
“Payload” folder. By default, the extension folders are located at:

Windows - C:\Program Files (x86)\Common Files\Adobe\CEP\extensions

For Lightroom Classic, the CLI utility is in the “PugetBench for Lightroom
Classic\Payload” folder inside the plugin download.

This utility requires a number of switches in order to function properly. The majority of the
switches are universal for every edition of the PugetBench CLI utility, but there are a few that
are specific for a particular benchmark.

While the benchmark will attempt to create application preferences and click through any typical
initial startup dialogs, we highly recommend manually launching each Adobe application
manually at least once before using the CLI utility.

Provided in the benchmark download is an example “CLI Sample...” .bat file that has the most
common options set. You can use this as a starting point, then customize or further refine the
benchmark run with the below switches.

Universal Switches
/license __________

*REQUIRED* License key for this benchmark. If you have a suite license, use the
same key for any of the Adobe benchmarks.
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Example: /license XXXXXXXX-XXXXXXXX-XXXXXXXX-XXXXXXXX

/activateonly
If this argument is used, the benchmark is not run, but the license key is activated
on the local system. Activation is typically done each time the benchmark is run,
but if you need the system to be offline, you can use '/activateonly' to reset the 30
day grace period before taking the system offline and running the actual
benchmark.

Example: /activateonly

/app_version __________
Version of the Adobe application to use. By default this is the latest version
supported by the benchmark, but some benchmarks support a limited number of
older versions. Run the CLI with the /? argument to see the list of supported
versions.

Default: latest version

Example: /app_version "22"

/test_location __________
Location to use for any disk-related tests.

Default: ~\Documents\PugetBench\APPNAME

Example: /test_location "D:\Benchmarks"

/run_count __________
Number of times to run the benchmark.

Default: 1

Example: /run_count 3

/rerun_count __________
Number of times to retry the benchmark if it or the Adobe application crashes.

Default: 0 (do not retry if there is a crash)

Example: /rerun_count 3

/copy_log __________
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Copy the benchmark log file to another location. If a file already exists, it appends
to the end. If this is not set, a .csv log file is still generated in your
Documents\PugetBench\*APPNAME*\*TIMESTAMP* folder, but just not copied
to a custom location.

Default: [blank]

Example: /copy_log "Q:\Results\Benchmark.csv"

/timeout __________
Minutes to wait for changes to the statuslog file before assuming something went
wrong and failing the benchmark run. Slower systems may need the timeout
increased to account for longer than typical render/export times

Default: 5

Example: /timeout 10

/upload_results
Uploads the results to our public benchmark database. This is enabled by default
on the free version of the benchmark, but opt-in for the commercial licensed
version when using the CLI utility.

Default: [disabled]

/clear_pref
Clears all of the application preferences for the relevant Adobe application. This
is a good idea to do if the Adobe application you are testing is not a fresh
installation. The benchmark is NOT run if this switch is used

Application Specific

Premiere Pro
/preset __________

Which benchmark preset to use. Options are “Standard”, “Extended”, and
“Custom”

Default: Standard

Example: /preset Extended
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/project_path __________
*REQUIRED* Path to the .prproj project to be used. Should point to the
Benchmark_Project.prproj file for standard & extended presets, or any .prproj file
for the custom preset.

Default: [blank]

Example: /project_path “D:\PugetBench for Premiere
Pro\Benchmark_Project.prproj”

/custom_tests
Allows you to specify which tests (comma separated) to run. Requires the /preset
argument to be set to "custom". To see the test number associated with each
test, launch the benchmark plugin manually, and switch the preset to “Custom”.
Each test and its corresponding test number will be shown in the benchmark
panel.

Default: [blank]

Example: /custom_tests "8,12"

/cooldown
Allows you to specify how many seconds the CLI will pause after a benchmark
run to let the system cool down, memory to be freed, etc.

Default: 20

Example: /cooldown 120

/custom_command
*Windows only*  Launches custom .bat files stored in C:/PugetBenchCommand
at various points during the benchmark. See previous section for detailed
information.

Default: [disabled]

After Effects
/preset __________

Which benchmark preset to use. Options are “Standard”, and “Custom”

Default: Standard
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Example: /preset Standard

/custom_tests
Allows you to specify which tests (comma separated) to run. Requires the /preset
argument to be set to "custom". To see the test number associated with each
test, launch the benchmark plugin manually, and switch the preset to “Custom”.
Each test and its corresponding test number will be shown in the benchmark
panel.

Default: [blank]

Example: /custom_tests "8,12"

/cooldown
Allows you to specify how many seconds the CLI will pause after a benchmark
run to let the system cool down, memory to be freed, etc.

Default: 20

Example: /cooldown 60

/custom_command
*Windows only*  Launches custom .bat files stored in C:/PugetBenchCommand
at various points during the benchmark. See previous section for detailed
information.

Default: [disabled]

Lightroom Classic
/project_path __________

*REQUIRED* Path to the “Benchmark Catalog.lrcat” catalog file to be used.

Default: [blank]

Example: /project_path “D:\PugetBench for Lightroom Classic\Benchmark
Catalog.lrcat”

Troubleshooting & Support
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If you have any issues with the benchmark not properly running, there are a number of things
you can try:

1. Check the individual benchmark pages to ensure that your system and software meets
the benchmark’s requirements.

2. Do not attempt to use the system while the benchmark is running. Unfocusing the
application window can break the benchmark in many situations.

3. Uninstall and reinstall the benchmark plugin.
4. Clear the Adobe application preferences either manually or with our Adobe CC

Preferences Backup/Restore/Clear Utility
5. Clear the cache files for the Adobe application.
6. Ensure the OS and Adobe application are set to English.
7. Make sure the path to the benchmark files does not have any special or non-English

characters.
8. The benchmark does not work over an unmapped network drive (I.E.

//192.168.1.2/Benchmark/). Mapped drives should work, but we highly recommend
having the benchmark on a local drive as network drives can lower performance.

9. Real-world benchmarks can be more sensitive to RAM, GPU, and other issues. If the
benchmark or Adobe application is crashing, you may have a hardware stability issue.

Lower than expected performance can be caused by a number of factors, but the most common
are:

1. Outdated BIOS/drivers/software
2. Windows power profile (High Performance is recommended for the best results)
3. Motherboard-specific CPU power limits
4. Adobe application settings not correct (GPU acceleration, hardware encoding/decoding,

etc.)
5. Background tasks (antivirus, Windows Update, etc.)

If you still have issues, we recommend posting in the comments section of the appropriate
benchmark page. If you have a commercial license, you can also contact us for support at:
benchmark-support@pugetsystems.com

Tips

For the most reliable benchmarking process, we recommend the following tips:
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● Clear the Adobe application preferences if it is not a fresh install. You can do this either
manually or with our Adobe CC Preferences Backup/Restore/Clear Utility. Launch the
application manually after clearing the preferences and check that important settings like
GPU acceleration are enabled.

● Do not attempt to use the system while the benchmarks are running. This can cause the
benchmarks to break, and even if it does not can result in lower benchmark results.

● Make sure the system is not set to go to sleep or hibernate.
● Make sure you are using the latest Windows version, drivers, and BIOS.
● As these are real-world tests, the results will not be exactly the same between runs and

can vary by as much as 5%. If you need highly accurate results, we recommend running
the benchmark multiple times and using either the average or fastest overall result.

● Display resolution can affect the results. We typically test at 3840x2160, but higher or
lower resolutions can result in slightly different results.
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